my 1999 acura TL, 3.2L v6 temp gauge says its running hot but I have no heat? on 1999 Acura TL

I have already found the actual radiator cap to be faulty, the whole spring mech was missing and it was just dumping coolant to the overflow tank. so I replaced that and I also replaced the thermostat. is there an coolant bleeder valve that i'm not seeing or is there another issue I should be considering?

Answers :

You need a second opinion or clarification on your issue ? ask it in the comment box OR you can Ask Your Question

Tips for a great answer:

  • Please provide as much detail as possible as this will allow our members to better understand and respond to your Comment
  • If you need clarification, ask it in the comment box
  • It's 100% free, no registration required

Suggested Questions/Answers :

It is recommended you read all this kind of situations

This content reflects information from various individuals and organizations and may offer alternative or opposing points of view.

my 1999 acura TL, 3.2L v6 temp gauge says its running hot but I have no heat? on 1999 Acura TL


I have already found the actual radiator cap to be faulty, the whole spring mech was missing and it was just dumping coolant to the overflow tank. so I replaced that and I also replaced the thermostat. is there an coolant bleeder valve that i'm n ...

engine runs hot after 60min of riding, but temp-guage only in middle-what gives on 1998 Acura Integra


when removing radiator cap it's bubbling over hot! Could it be my thermastat not opening? ...

temp gauge shows running hot, but motor temp is normal on 1996 Mercedes-Benz C220


temp gauge shows normal temp 60%, pegs out in red or a little below 120c 40% of running time. When 120c or in red, front 2 fans run and a/c temp gets warm, but motor temp shoes normal with laser temp gauge. Have replaced 2 temp sensors and related pa ...

Car was run while temp. gauge said "hot", next day oil pressure light on. on 2005 Hyundai Accent


On Tues, had a radiator replaced, thought it was fine, was out in the boonies the next day, far from home, and it ran hotter than usual. Then went into red, but came out of it at times. Probably had 10-15 mins of running while in red zone. Had antifr ...

what is it when a/c runs cold then hot and temp gauge runs hot? on 2005 Ford Taurus


this happened one day and then saw steam coming from under hood. filled radiator up ran fine for two days and then did same thing. ...

Mil lamp says AC is off when I run defrost or heat in cold cond and thermo is 0 on 2008 Chevrolet Colorado


Start truck everything is fine?drive five miles or so heat goes cool the mil lamp says AC is off and temperature gauge goes to zero. Then mil lamp stays on and the heat gets intensely hot but temperature gauge is at zero.then starting the truck later ...

Temperature running hot. Heats up to 75% of the temp gauge but no higher on 2000 Ford Escort


I have a 2000 Ford Escort ZX2. Recently, I noticed the car temp was running a bit high. As I watched it while driving, the temp was slowly climbing, especially during stop and go traffic. I figured out the fan wasn't coming on, and replaced th ...

Engine stumbles and dies in hot weather hot engine normal operating temp on 1994 Ford Thunderbird


let sit starts back up runs a while dies again, only hot weather and hot engine but normal operating temperature engine cooling system has never overheated, usually at low rpm's and idle but will occur at hwy speeds also. multiple ign modules rep ...

Temp on dashboard gauge reads cold whether engine is running normal or hot. on 1997 Ford Taurus


After driving 70 miles, the temp gauge never went to the middle between hot and cold, but stayed close to cold. The engine did not appear overly hot. However on the return trip in the evening, the temp remained the same while the engine seemed very ...

Coolant level is fine but temp gauge runs to hot, also white smoke from exhaust on 1997 Ford Explorer


white smoke from exhause about 5 min when first start truck now temp gauge running to hot when coolant level is fine. Just purchased truck 2 days ago, think I brought a lemon. ...

my car has been running hot,im losing fluid but not sure where its going. on 1997 Acura CL


it runs hot every other day .i sometime have lil spots of fliud by my driver side tire. ...

why would my 2007 chevy uplander with 3.9 run a little hot? on 2007 Chevrolet Uplander


I have to add about a 1/2 gallon of water every week. but it doesnt seem to be leaking at all. However it does seem to run a little warm and steam comes out of the overflow tank. But the guage says its normal temp. about once a week it runs hot and s ...

Car is running hot. on 1999 Nissan Pathfinder


I have a 1999 Nissan Pathfinder. I'm having a problem with it running hot. If I drive somewhere within 15 miles, it runs at normal temp, but it seems like whenever I drive further it runs hot. My brother says there's no pressure in the coo ...

Why does my warning light comes on sometimes when my temp gauge says its not hot on 2004 Mazda RX-8


Its mainly when its a hot day or in driving over 70mph but the temperature gauge is displaying no more than 50% on the scale from cold to hot! ...

When hot outside and I have the a/c on my vehicle running the engine temp rises. on 2000 Dodge Durango


The temp will rise almost to the point of over heating. As soon as I turn the A/C off the temp drops down after a few minutes while I am driving. ...

The temp gauge shows that car is running hot. on 1997 Cadillac Seville SLS


After checking all hoses and checked for possible leaks, then changed out the thermostat and replaced water pump, the temp gauge will still move towards red zone. What or where should I look next? ...

Hey , I reasonlly had to change out my radiator an water pump n replace heater core n hoses n did put in new temp sensor n thermostat.. n put antifreeze in with bleeder valve open an my car still runs hot with in 20mins of driving do I need to replace tem on 2002 Chrysler Concorde


I put temp an thermostat in at same time but when added antifreeze then didn't know had to open bleeder valve then so I drain all old antifreeze out an added new with bleeder valve open ...

Heater works & engine temp good when parked,& driving no hot air & car runs cold on 1997 Honda Civic


At speed I have no heat or minimal heat and engine temperature is cold. When I'm parked the engine temperature warms and I get hot air? What is causing this? ...

When the weather is hot the car runs sluggish temp. Gage is fine on 2004 Mitsubishi Outlander


Check engine light is not on and in the mornings it runs fine ...

black smoke coming out of my exhaust and is running hot on 1997 Acura TL


after I left work last night my needle was reading hot way up there and after 4-miles into my 8-mile drive home massive black smoke was spewing from my exhaust pipes and smoke from under the hood and it died out about 2-blocks from home it started ba ...

what wld make it run hot? replaced thermostat and water pump. still runs hot. on 2002 Mitsubishi Lancer


the gage says hot and then suddenly drops half way back down then back to hot again.. doesnt affect the way it drives or runs though. what cld that b? ...

vehicle leaking antifreeze temp gauge went to hot antifreeze running into resevo on 2001 Chrysler 300M


antifreeze being pushed into the resevoir just had some oil hoses replaced would this have anything to do with it ...

A detailed question is important to get you a relevant answer .

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
all rights reserved to the respective owners || cheapestukipodrepairs.com || Terms of Use || Contact || Privacy Policy
Load time: 0.2070 seconds