temp gauge shows running hot, but motor temp is normal on 1996 Mercedes-Benz C220

temp gauge shows normal temp 60%, pegs out in red or a little below 120c 40% of running time. When 120c or in red, front 2 fans run and a/c temp gets warm, but motor temp shoes normal with laser temp gauge. Have replaced 2 temp sensors and related parts. I think there is a short between gauge and sensor. No rime or reason to when it acts up, cold- hot - wet - dry, etc. help

Answers :

You need a second opinion or clarification on your issue ? ask it in the comment box OR you can Ask Your Question

Tips for a great answer:

  • Please provide as much detail as possible as this will allow our members to better understand and respond to your Comment
  • If you need clarification, ask it in the comment box
  • It's 100% free, no registration required

Suggested Questions/Answers :

It is recommended you read all this kind of situations

This content reflects information from various individuals and organizations and may offer alternative or opposing points of view.

temp gauge shows running hot, but motor temp is normal on 1996 Mercedes-Benz C220


temp gauge shows normal temp 60%, pegs out in red or a little below 120c 40% of running time. When 120c or in red, front 2 fans run and a/c temp gets warm, but motor temp shoes normal with laser temp gauge. Have replaced 2 temp sensors and related pa ...

temp gauges are showing higher readings than normal.while car is running only getting 12.7v , new alt & battery and volt reg. and 12.6v from battery when car is off, temp gauge shows right temp when key is in on position , , any ideas?? on 1995 Ford Mustang GT


And the temp and oil gauges show higher readings when I turn headlights on, I put HIDs headlights in, ABS light also came on when I installed them, but headlights work but high beam light stays on then when you hit the dimmer the headlights go off, i ...

My 96 C220's temp gauge, gas, speedodometer,and tacodometer are not working. on 1996 Mercedes-Benz C220


I went on a trip last week, all of a sudden it was working. I stopped to get gas, when I started the car to leave the gag station it wasn't working again. the digital milage and trip odometer along with lights work fine. Where do I start, the rad ...

Temp gage increases when a/c runs is this normal? Would coolant flush help? on 1998 Mercedes-Benz C280


What should my temperature gage always be at? Currently it stays at 81-82 then turn on air condition it goes up to about 88. Is this normal? ...

temp gauge shows overheating during a.c is running on. on 2002 Toyota Corolla


As per the advice of repair shop, they turn of the collant termostate,now, until a minimum running time it can't be middle in my temp gauge.And , my car run in CNG/Octane.If i run the car in CNG with a.c load,some times the temp gauge getting hig ...

What is the optimum engine temp (on the gauge)? on 2000 Mercedes-Benz CL500


On my car it goes over the middle (90) looks like running a bit warm....sometime it reaches 100. is this normal? ...

My temp gauge and the gas gauge have just turned on permanently. Is this a fuse on 1999 Mercedes-Benz ML430


The Mercedes ML430 is showing the gauge of low oil pressure just recently. Then the light of temperature and gas light came on at the same time too. Is this possibly a fuse? ...

My truck runs rough and loses power and the temp gauge shows false readings. on 2006 Dodge Ram 2500


When the truck is under a load, such as plow on or pulling trailer up inclines, the temp gauge begins to climb and the truck loses power and runs rough. This starts to happen after driving a few miles. The gauge will even red line then go right bac ...

The water temp and rpm gauges drop to zero and then back to correct frequently. on 1999 Mercedes-Benz SLK230


When they do the water level and oil pressure alarms come on. Fuel gauge and RPM stay steady except occasionally when everything goes crazy for a moment. While all this is happening the car runs perfectly ...

fuel gauge after a full tank would read 0, drive for 50 miles and gauge OK on 2000 Mercedes-Benz ML320


every time I refuel my fuel gauge would read 0 when you start engine. After driving for 50 miles the gauge will start to go up and read full. this happen every time I refuel. ...

S550 runs rough when cold and engine sounds like boat car runs normal when warm on 2007 Mercedes-Benz S550


engine is not smooth when cold, exhaust from engine is loud and throaty when cold, once car is fully warm, car runs smooth and quiet. ...

1989 420 SEL runs poorly after cold start and must be restarted to run correctly on 1990 Mercedes-Benz 420SEL


Engine starts fine and idles okay, but has no power, economy gage all the way in red, doesn't shift properly. Does not straighten out even after up to normal temp unless engine is shut off and restarted. Can restart after driving a short distan ...

by the way,your model selections do not show C220. my car is a C220 CDI. 2001 on 2001 Mercedes-Benz C240


It smokes heavily when runing, with very black sooty smoke coming out of the exhaust. We have changed the oil and oil filters. but no way. Whats wrong and pls help. thanks ...

my car is running very bad. runs better cool before it gets up to temp. on 1991 Mercedes-Benz 300E


there is no engine noise at all, 275000 miles. the hudraulic actuator has been replaced but now it seems worse. ...

When outside temp is above 85-90 and the A/C is on shifting is not normal. on 2014 Mercedes-Benz E350


Car hangs up in 3rd and 4th gears for as much as 15 minutes when outside temp is high and A/C is on. Does not shift to higher gears until more than 2K rpm during normal acceleration. Resumes normal shifting patterns after about 15-20 minutes. ...

Temp on dashboard gauge reads cold whether engine is running normal or hot. on 1997 Ford Taurus


After driving 70 miles, the temp gauge never went to the middle between hot and cold, but stayed close to cold. The engine did not appear overly hot. However on the return trip in the evening, the temp remained the same while the engine seemed very ...

Is their a schematic for ignition key and dash gauges. I lose power to gauges on 1997 Mercedes-Benz SL320


I lose power to the gauges when I turn key in ignition(all gauges-speedometer, tach mpg,temp, and all lights except seat belt light.The odometer and outside temp are on when I open the door but go out when I turn the ignition key to the run or start ...

how do u change the intake air temp sensor sensor on 1996 Mercedes-Benz C220


I have a 96 c220, the check engine light came on so I took it to autozone and they said it was a bad intake air temp sensor, I orderded the part and now I would like to know how to replace the sensor and get my check engine light to go off so that my ...

The temp gauge shows that car is running hot. on 1997 Cadillac Seville SLS


After checking all hoses and checked for possible leaks, then changed out the thermostat and replaced water pump, the temp gauge will still move towards red zone. What or where should I look next? ...

gas gauge inop. cluster illum. inop. courtesy lights inop. on 1996 Mercedes-Benz C220


fuel gauge does not work,move slightly on start-up ,then nothing. interior lights dont come on anytime. gauge cluster illumination lights dont come on anytime. all fuses are good.any leads on related relays and there locations, trouble shooting tips ...

is it normal for the a/c fan located in the engine compartment to run continuous on 2002 Mercedes-Benz ML320


the fuse control to the a/c fan gets blown frequently now. i thought the a/c fan runs intermittently and stops.can it be why the fuse gets blown frequently? ...

i replaced my exterior temp sensor and it does not show it on the dash. reset??? on 2006 Mercedes-Benz S350


is there anything i have to do to reset it or could it be a wiring problem. but heres the good part i put through a touchless car wash and the high pressure of the water turned it on for 3 days and it reading a real high temp but then it stopped work ...

All instrument panel gauges read zero; no speed, no temp, no RPM's; antitheft device and traction control lights are on. Car drives and runs normal. on 2011 Chevrolet Cruze


Just happened last night and continues this morning. Have been smelling an intermittent electrical smell for several weeks. ...

A detailed question is important to get you a relevant answer .

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
all rights reserved to the respective owners || cheapestukipodrepairs.com || Terms of Use || Contact || Privacy Policy
Load time: 0.2047 seconds